||
Skip to end of metadata
Go to start of metadata

What is new in this release 

The WSO2 API Manager version 1.9.0 is the successor of version 1.8.0. It contains the following new features, enhancements and changes:

Compatible WSO2 product versions

These are the products that were tested for compatibility with WSO2 APIM 1.9.0:

  • WSO2 Governance Registry 4.6.0
  • WSO2 Identity Server 5.0.0 SP01
  • WSO2 Business Activity Monitor 2.5.0

WSO2 APIM 1.9.0 is based on WSO2 Carbon 4.2.0 and is expected to be compatible with any other WSO2 product that is based on the same Carbon version. If you get any compatibility issues, please contact team WSO2. For information on the third-party software required with APIM 1.9.0, see Installation Prerequisites.

What has changed in this release

This release includes the following features/functionalities that were deprecated (might be removed in a future release) and a feature/functionality that was removed.

Deprecated features and functionalities

  • WSDL endpoints are deprecated in this version. For any existing APIs with WSDL endpoints, you can see the WSDL option activated in the edit mode.
  • The error codes 900903 (Access token expired) and 900904 (Access token inactive) are deprecated. We now use the error code 900901 for Error Handling.

Removed features and functionalities

The integrated WSO2 REST client in the API Store, which was deprecated in API Manager 1.8.0, has been retired in API Manager 1.9.0. We now encourage users to use the Swagger Console to invoke your APIs

This section describes the specific deprecated features of WSO2 API Manager 1.9.0. To view previously deprecated features, see the About this Release page of the previous version.

Fixed issues

For a list of fixed issues in this release, see WSO2 API Manager 1.9.0- Fixed Issues.

Known issues

For a list of known issues, see WSO2 API Manager 1.9.0- Known Issues. 

  • No labels