||
Skip to end of metadata
Go to start of metadata

What is new in this Release 

The WSO2 BAM version  2.5.0 is the successor of version 2.4.1It contains the following new features and enhancements.

New Features

Improvements

Compatible WSO2 product versions 

You can make any WSO2 product compatible with WSO2 BAM after installing a data agent. Data agents allow the product to communicate with the BAM server and send statistics for analysis. The following products have the latest compatible data agents in them by default, and therefore are compatible with BAM 2.5.0 (or any other BAM version):

  • APIM 1.8.0 
  • AS 5.2.1
  • ESB 4.8.1  
  • ELB 2.1.1

If a particular product version you are using does not have a data agent installed, follow the steps below to install one:

  1. Check the WSO2 Release Matrix and identify the WSO2 Carbon version that your product is based on.
  2. Go to WSO2 P2 repositories and select the repository that is based on the Carbon version you selected in the previous step.
  3. Add the feature repository to your product. 
  4. Then, select the data agent that you need from the features in the repository, and install it in your product. For example, in order to send mediation statistics from WSO2 ESB to BAM, you must install Mediation Statistics Data Agent feature.

For information on the third-party software required with BAM 2.5.0, see Installation Prerequisites.

Deprecated features

  • Removal of REST API support provided by BAM 2.4.x and prior. Instead of the REST API, you can use HTTP input event adapter with BAM 2.5.0 for the same use case.

Fixed issues

For a list of fixed issues in this release, see WSO2 BAM 2.5.0 - Fixed Issues.

Known issues

For a list of known issues in this release, see WSO2 BAM 2.5.0 - Known Issues .

  • No labels