This documentation is for WSO2 Enterprise Integrator version 6.1.1 . View documentation for the latest release in the 6.x.x family and the latest release in the 7.x.x family.

All docs This doc
Skip to end of metadata
Go to start of metadata

WSO2 Enterprise Integrator version (WSO2 EI) is the next level of the ESB, which provides a powerful integration solution that brings together the functionalities encapsulated in the following WSO2 products:

  • WSO2 Enterprise Service Bus (ESB)
  • WSO2 Data Services Server (DSS)
  • WSO2 Business Process Server (BPS)
  • WSO2 Message Broker (MB)

The features of the above products are encapsulated in WSO2 EI as several runtimes. WSO2 EI version 6.1.1 is the successor of version 6.1.0, and it comes complete with the following profiles, tooling, and analytics in a single release. 

  • ESB profile: Consists of WSO2 ESB and WSO2 DSS. 
  • Business Process profile: Consists of WSO2 BPS for handling long-running business processes. 
  • Message Broker profile: Consists of WSO2 MB for brokering and reliable messaging. 
  • MSF4J profile: Provides the capability of creating microservices in Java, to facilitate your integration use cases.
  • Analytics profile: Provides the capability of monitoring statistics of integration flows (processed in the Integration runtime) as well as business process (processed in the Business Process runtime). 

For more information, see Introducing the Enterprise Integrator.

What's new in this release

WSO2 EI 6.1.1 is a patch release that is shipped with the following fixes: Fixed issues.

From WSO2 EI 6.1.0 onwards, it does not ship the functionalities of WSO2 Application Server (AS). However, you can develop applications using MSF4J, JAX-RS or JAX-WS technologies and deploy in WSO2 EI. If you already have applications in WAR or AAR formats, use WSO2 AS 5.3.0 or Tomcat as the server to deploy web apps. Nevertheless, WSO2 still provides complete development and production support for WSO2 AS.

Compatible WSO2 product versions

WSO2 EI 6.1.1 is based on WSO2 Carbon 4.4.16 and is expected to be compatible with any of the WSO2 products that are based on any Carbon 4.4.x version. If you get any compatibility issues, contact team WSO2. For information on the third-party software required with EI 6.1.1, see Installation Prerequisites. For more information on the product releases (i.e., released date etc.) done in each Carbon platform release, see the Release Matrix.

Known issues

For a complete list of known issues in this release, see WSO2 EI - Open Issues.

  • No labels