||
Skip to end of metadata
Go to start of metadata

Published: 02nd September 2019

Severity: High

CVSS Score: 7.3 (CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N)


AFFECTED PRODUCTS

WSO2 API Manager: 2.6.0

WSO2 Identity Server: 5.3.0 , 5.4.0 , 5.4.1 , 5.5.0 , 5.6.0 , 5.7.0


OVERVIEW

Improper Authentication and Authorization vulnerability has been identified in SCIM API in WSO2 Identity Server.

DESCRIPTION

By obtaining a certificate from a trusted certificate authority, it is possible to bypass authorization if the root certificate authority used to sign is available in the client trust store.


IMPACT

Upon successful exploitation of this vulnerability, an unauthorized user would be able to invoke the SCIM API


SOLUTION

Upgrade the WSO2 Identity Server version to 5.8.0 or higher which are not affected by this vulnerability.


For other Affected products


Apply the following patch based on your product version by following the instructions in the README file. If you have any questions, post them to [email protected].

Please download the relevant patch based on the product you use following the matrix below. The patch can also be downloaded from http://wso2.com/security-patch-releases/.


Code

Product

Version

Patch

AM

WSO2 API Manager

2.6.0

WSO2-CARBON-PATCH-4.4.0-4153


Note: If you are a WSO2 customer with Support Subscription, please use WSO2 Update Manager (WUM) updates in order to apply the fix. This patch is intended for WSO2 community (free) users.


NOTES

If you are using newer versions of affected products than the ones mentioned in the “SOLUTION” section, this vulnerability is fixed.


  • No labels