Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Published: 5th March 2021

Version: 1.0.0

Severity: Medium

CVSS Score: 4.6 (CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N)


AFFECTED PRODUCTS

WSO2 API Manager : 3.0.0 or earlier
WSO2 API Manager Analytics : 2.2.0 , 2.5.0
WSO2 API Microgateway : 2.2.0
WSO2 Enterprise Integrator : 6.6.0 or earlier
WSO2 IS as Key Manager : .5.0 , 5.6.0 , 5.7.0 , 5.9.0
WSO2 Identity Server : 5.4.0 , 5.4.1 , 5.5.0 , 5.6.0
WSO2 Micro Integrator : 1.0.0


OVERVIEW

A potential XML External Entity (XXE) vulnerability has been identified in components used in API Manager.


DESCRIPTION

An XML External Entity (XXE) attack abuses a widely available but rarely used feature of XML parsers to access sensitive information.


IMPACT

The resolution of external entity references is enabled. Therefore, if attacker-controlled XML is submitted to the XML parser, then the attacker could gain access to information about an internal network, local filesystem, or other sensitive data.


SOLUTION

If you are using an affected product version, it is highly recommended to migrate to the latest released version to receive security fixes.

You may also apply the relevant fixes based on the changes from the public fixes: https://github.com/wso2/carbon-commons/pull/407, https://github.com/wso2/product-apim/pull/7456, https://github.com/wso2/carbon-registry/pull/348, https://github.com/wso2/carbon-event-processing/pull/316, https://github.com/wso2/carbon-analytics-common/pull/739, https://github.com/wso2/carbon-governance/pull/336

Note: If you are a WSO2 customer with Support Subscription, please use WSO2 Update Manager (WUM) updates in order to apply the fix.