Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Application

Purpose

Version

Notes

Oracle Java SE Development Kit (JDK)

  • To launch the product as each product is a Java application.
  • To build the product from the Source distribution (both JDK and Apache Maven are required).
  • To run Apache Ant

1.6.x or higher (1.6.0_24 onwards recommended for production)

Oracle and IBM JRE 1.7 are also supported when running (not building) WSO2 products.

Required by all WSO2 products

Apache ActiveMQ
JMS Provider

  • To enable the product's JMS transport and try out JMS samples. The ActiveMQ client libraries must be installed in the product's classpath before you can enable the JMS transport.

5.5.0 or higher

If you use any other JMS provider (e.g. Apache Qpid), install any necessary libraries and/or components.

Currently needed by WSO2 ESB to run its JMS samples

Apache Ant

  • To compile and run the sample clients.

1.7.0 or later

Required by all WSO2 products to run product samples

Apache Maven

  • To build the product from the source (both JDK and Apache Maven are required).

2.1.0 to 3.0.0

Required by all WSO2 products when installing from source distribution

SVN Client

Can be downloaded form,

Required by all WSO2 products

Web Browser

  • To access the product's Management Console. The Web Browser must be JavaScript enabled to take full advantage of the Management console.
  • NOTE: On Windows Server 2003, it is not allowed to go below the medium security level in Internet Explorer 6.x.

 

Required by all WSO2 products

...