This documentation is for WSO2 Message Broker 3.0.0. View documentation for the latest release.
Due to a known issue do not use JDK1.8.0_151 with WSO2 products. Use JDK 1.8.0_144 until JDK 1.8.0_162-ea is released.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Application

Purpose

Version

Download Links

Oracle Java SE Development Kit (JDK)*

JDK 7 or 8.

Do not use
Note
titleImportant!

Some updates of JDK 1.8 (for example, JDK1.8.0_151

due to a

) are affected by a known issue

. This

 related to GZIP decoding. Until this issue is fixed

in JDK 1

, we recommend one of the following approaches:

  • Use either JDK1.8.0_
162-ea. However, use JDK 1.
  • 144 or JDK1.8.0_
144 until the latter mentioned version is released.
Note
  • 077 updates. We have verified that these versions are not affected by the known issue.
  • Alternatively, you can disable GZIP decoding for your product by following the steps given below. This will ensure that your product is not affected by the known issue.
    1. Open the catalina-server.xml file from the <PRODUCT_HOME>/repository/conf/tomcat/ directory.
    2. Set the compression parameter (under each of the connector configurations) to false as shown below:

      Code Block
      compression="off"
    3. Restart the server.

Also, note that only 64-bit JDK can be used for WSO2 MB.

http://java.sun.com/javase/downloads/index.jsp

Apache Ant

  • To compile and run the product samples.

1.7.0 or later

http://ant.apache.org/ 

Git


Apache Maven

  • To build the product from the source distribution (both JDK and Apache Maven are required). If you are installing by downloading and extracting the binary distribution instead of building from the source code, you do not need to install Maven.

http://maven.apache.org/ 

Web Browser

  • To access the product's Management Console. The Web Browser must be JavaScript enabled to take full advantage of the Management console.
Note

On Windows Server 2003, you must not go below the medium security level in Internet Explorer 6.x.