Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Published: 4th Aug 2021

Version: 1.0.0

Severity: Medium

CVSS Score:   6.5 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L)


AFFECTED PRODUCTS

WSO2 API Manager : 2.6.0 , 3.0.0 , 3.1.0 , 3.2.0
WSO2 IS as Key Manager : 5.7.0 , 5.9.0 , 5.10.0
WSO2 Identity Server : 5.7.0 , 5.8.0 , 5.9.0 , 5.10.0


OVERVIEW

Improper OAuth 2.0 tokens validation vulnerability.


DESCRIPTION

The vulnerability leads to treating the access tokens and the refresh tokens of disabled user accounts as active when validated.


IMPACT

Due to this vulnerability, a disabled user with an already issued access token or a refresh token might be able to access resources which are now unauthorized. This may impact confidentiality, integrity and availability of those resources, depending on the provided functionality.


SOLUTION

If you are using an affected product version, it is highly recommended to migrate to the latest released version to receive security fixes.

You may also apply the relevant fixes based on the changes from the public fix: https://github.com/wso2-extensions/identity-inbound-auth-oauth/pull/1501

Note: If you are a WSO2 customer with Support Subscription, please use Update 2.0 or WSO2 Update Manager (WUM) updates in order to apply the fix.