Child pages
  • Installation Prerequisites

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Application

Purpose

Version

Download Links

Oracle Java SE Development Kit (JDK)*

Required to:

1.6.*/1.7.*

Info
  • If you are using JDK 1.6, you might need to replace the Java Cryptography Extension (JCE) policy files in your JDK with the Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy files. This will avoid "illegal key size" errors when you try to invoke a secured Web service.
  • To build the product from the source distribution, you must use JDK 1.6 instead of JDK 1.7.
  • Oracle and IBM JRE 1.7 are supported when running (not building) WSO2 products.
  • We do not recommend OpenJDK.
Info

If you are using JDK7 on Mac OS, follow the steps below to install the Snappy-java library: 

  1. Download the Snappy JAR file from here, and extract it to a preferred location. We will refer this extracted folder as <SNAPPY_HOME>.
  2. In <SNAPPY_HOME>/org/xerial/snappy/native/Mac/ folder, you find the Snappy java library files (.jnilib files) as i386 (32bit) and x86_64 (64bit). Copy the appropriate one to <CEP_HOME>.

For more information on installing snappy-java library, see Snappy-java fails on Mac OS JDK 1.7.

SVN ClientTo check out the code to build the product from the source distribution. If you are installing by downloading and extracting the binary distribution instead of building from the source code, you do not need to install SVN. 

Apache Maven

To build the product from the source distribution (both JDK and Apache Maven are required). If you are installing by downloading and extracting the binary distribution instead of building from the source code, you do not need to install Maven.

Web Browser

Required by all WSO2 products to To access each product's Management Console . The Web Browser must be JavaScript enabled to take full advantage of the Management console.

Info

On Windows Server 2003, you must not go below the medium security level in Internet Explorer 6.x.


  

You are now ready to install. Click one of the following links for instructions: