This documentation is for WSO2 Private PaaS 4.0.0. View documentation for the latest release.
Page Comparison - Installation Prerequisites (v.3 vs v.4) - WSO2 Private PaaS 4.0.0 - WSO2 Documentation

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Table of Contents
maxLevel3

System Requirements

Memory

Minimum 8GB RAM is recommended for a POC level project and 16GB RAM is recommended for production environments.

For example: m3.large for a POC level project and m3.xlarge for production environments, if EC2 is used.

Processor 2.8GHz CPU
Disk~ 40GB hard disk space

Required applications

ApplicationPurposeVersionDownload Links
Oracle Java SE Development Kit (JDK)

Required by all the products:

  • To launch the product, as each product is a Java application.
  • To build the product from the source distribution (both JDK and Apache Maven are required).

1.6.24 or later / 1.7.*

  • If you are using JDK 1.6, you might need to replace the Java Cryptography Extension (JCE) policy files in your JDK with the Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy files. This will avoid "illegal key size" errors when you try to invoke a secured web service.
  • If you want to build the product from the source distribution, you must use JDK 1.6 instead of JDK 1.7.
  • Oracle and IBM JRE 1.7 are also supported when running (not building) WSO2 products.

http://java.sun.com/javase/downloads/index.jsp

Info

If you wish to get support for 32 bits in WSO2 Private PaaS, download the Java 32 bits distribution.

MySQL Connector for JavaRequired as a standardized database driver for Java platforms and development.1.7.0 or laterhttp://dev.mysql.com/downloads/connector/
Git

Required to check out the source from the Git repository.


1.9.0 or laterhttp://git-scm.com/downloads/
Apache Maven

Required to build the product from the source distribution.

 3.0.3 or later
http://maven.apache.org

If required, you can use the following commands to manually install and download Apache Maven:

Code Block
sudo apt-get update
sudo apt-get install maven
RubyRequired as a prerequisite for cartridges.2.1.0 or laterhttps://www.ruby-lang.org/en/downloads/
Zip UtilityRequired to compress and unzip packages used.AnyChoose a zip utility that is compatible with the OS.
Linux Base ImageRequired as a prerequisite for cartridges.2.6.0 or laterhttps://packages.debian.org/squeeze/linux-base/
FacterRequired as a prerequisite for cartridges.2.0.0 or laterhttps://downloads.puppetlabs.com/facter/
AMQP Message BrokerRequired to communicate with the Cloud Controller and other profiles.5.9.1

If an AMQP message broker is not already installed in your machine, Apache ActiveMQ will get installed when the boot.sh script is executed during the product configuration.

Info

Currently Apache ActiveMQ is used as the default Message Broker. However, other AMQP Message Brokers (e.g., WSO2 Message Broker and RabbitMQ) are supported as well.

Puppet

Required to manage and automate system configurations.

 


3.0

If Puppet, is not already installed in your machine,it will get installed when the boot.sh script is executed during the product configuration.

Info

Install Puppet Master in the same machine.

Environment Compatibility

  • All WSO2 Carbon-based products are Java applications that can be run on any platform that is Oracle JDK 1.6.*/1.7.* compliant. JDK 1.8 is not supported yetAlso, we do not recommend or support OpenJDK.
  • For environments that WSO2 products are tested with, see Compatibility of WSO2 Products. 
  • If you have difficulty in setting up any WSO2 product in a specific platform or database, please contact us.
Operating Systems

Linux (Ubuntu 12.04 64bit server or SUSE Linux Enterprise 11 SP2)

Info

If you wish to get support for 32 bits in WSO2 Private PaaS, download the Java 32 bits distribution.