This documentation is for WSO2 API Manager 1.8.0 View documentation for the latest release.
Page Comparison - Installation Prerequisites (v.3 vs v.20) - API Manager 1.8.0 - WSO2 Documentation

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Prior to installing any WSO2 Carbon based product, it is necessary to have the appropriate prerequisite software installed on your system. Verify that the computer has the supported operating system and development platforms before starting the installation.

System requirements

Memory

  • ~ 2 GB minimum
  • ~ 512 MB heap size. This is generally sufficient to process typical SOAP messages but the requirements vary with larger message sizes
and  the
  • and the number of messages processed concurrently.

Disk

  • ~
180
  • 500 MB for a fresh installation pack, excluding space allocated for log files and databases.
CPU
  • ~ Recommended minimum - 2 Cores. For high concurrencies and better performances - 4 Cores.

Environment compatibility

...

Operating Systems / Databases

  • All WSO2 Carbon-based products are Java applications that can be run

...

  • on any platform that is Oracle JDK 1.6.*/1.7.* compliant. JDK 1.8 is not supported yet. 
  • All

...

  •  WSO2 Carbon-based products are generally compatible with most common DBMSs. The embedded H2 database is suitable for development, testing, and some production environments. For most enterprise production environments, however, we recommend you use an industry-standard RDBMS such as Oracle, PostgreSQL, MySQL, MS SQL, etc. For more information,

...

  • see Working with Databases. Additionally, we do not recommend the H2 database as a user store.
  • It is not recommended to use Apache DS in a production environment due to scalability issues. Instead, use an LDAP like OpenLDAP for user management.
  • For environments that WSO2 products are tested with,

...

Required applications

The following applications are required for running the API Manager and its samples or for building from the source code. Mandatory installs are marked with *.

Application

Purpose

Version

Download Links
Oracle

Java SE Development Kit (JDK)*

Required to,

1.6.27 or later / 1.7.*

  • If you are using JDK 1.6, you might need to
install
files to
  •  files. This will avoid "illegal key size" errors when you try to invoke a secured
web
  • Web service.
  • To build the product from the source distribution, you must use JDK 1.6 instead of JDK 1.7.
  • Oracle and IBM JRE 1.7 are also supported when running (not building) WSO2 products.
  • If you are using JDK 1.7 on a Mac OS, install the snappy-java library using the following steps:

    1. Download the snappy-java JAR and extract it to a preferred location. This folder will be referred to as <SNAPPY_HOME>.

    2. Copy the appropriate snappy-java library file i386.jnilib (32bit) or x86_64.jnilib (64bit), which is in the <SNAPPY_HOME>/org/xerial/snappy/native/Mac/directory, to the <APIM_HOME> directory.
    For more information on installing snappy-java library, see Snappy-java fails on Mac OS JDK 1.7.
  • We do not recommend OpenJDK.
  • Apache ActiveMQ JMS Provider

    • To enable the product's JMS transport and try out JMS samples. The ActiveMQ client libraries must be installed in the product's classpath before you can enable the JMS transport.

    5.5.0 or later

    If you use any other JMS provider (e.g., Apache Qpid), install any necessary libraries and/or components.

    http://activemq.apache.org

    Apache Ant

    1.7.0 or later

    http://ant.apache.org
    SVN Client
     

    Apache Maven

    • To build the product from the source distribution (both JDK and Apache Maven are required). If you are installing by downloading and extracting the binary distribution instead of building from the source code, you do not need to install Maven.

    Web Browser

    • Required by all WSO2 products to access each product's Management Console. The Web Browser must be JavaScript enabled to take full advantage of the Management console.

    NOTE: On Windows Server 2003, you must not go below the medium security level in Internet Explorer 6.x.

     

     



    You are now ready to install. Click one of the following links for instructions: