For environmental capabilities on the latest WSO2 products, see the Product Compatibility section in the respective WSO2 product documentation.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

ProductVersion/sSupported JDK version/sSupported Operating System/s

WSO2 API Manager (APIM)

3.0.0Go to WSO2 API Manager 3.0.0 - Product Compatibility.
WSO2 Identity Server5.9.0See WSO2 Identity Server 5.9.0 - Environment Compatibility.
WSO2 Enterprise Integrator (EI)7.1.0See WSO2 Micro Integrator 1.2.0 - Environment Compatibility.
6.6.0
  • CorrettoJDK 8
  • AdoptOpenJDK 8
  • AdoptOpenJDK 11
  • OpenJDK 8
  • Oracle JDK 8
  • Oracle JDK 11
  • Ubuntu 18.04
  • CentOS 7.4, 7.5
  • Red Hat Enterprise Linux 7.0
  • SUSE Linux 12
  • Windows Server 2016
  • RHEL-8
WSO2 Enterprise Integrator (EI)

6.5.0

  • CorrettoJDK 8
  • AdoptOpenJDK 8
  • OpenJDK 8
  • Oracle JDK 8
  • Ubuntu 18.04
  • CentOS 7.4, 7.5
  • Red Hat Enterprise Linux 7.0
  • SUSE Linux 12
  • Windows Server 2016
WSO2 Micro Integrator 1.0.0 (MI)1.0.0
  • CorrettoJDK 8
  • AdoptOpenJDK 8
  • OpenJDK 8
  • Oracle JDK 8
  • CentOS 7.5
  • SUSE Linux 12
WSO2 Open Banking (OB)1.4.0
  • Oracle JDK 8
  • OpenJDK 8
  • Ubuntu 16.04

WSO2 Stream Processor

4.x.x
  • OpenJDK 8
  • Oracle JDK 8
  • Windows 7,10
  • Ubuntu 16.04, 17.04, 18.04
  • MacOS High Sierra

...