This documentation is for WSO2 Message Broker 3.0.0. View documentation for the latest release.
Due to a known issue do not use JDK1.8.0_151 with WSO2 products. Use JDK 1.8.0_144 until JDK 1.8.0_162-ea is released.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. To run the samples, you must have the correct versions of the following installed.
    • Java Development Kit/JRE 
    • Apache Ant
    • Apache Maven 
    See the Installation Prerequisites section for more details.
  2. If you want to run MB in DEBUG mode, you need to set the log level to DEBUG for the relevant appender as explained in Logging Configuration.
  3. A sample can be build using Apache Ant and/or Apache Maven. Make sure that the following dependencies are saved as required:
    1. A sample built using Apache Ant requires the following files to be saved in <MB_HOME>/client-lib directory. Note that these JARs are included in the WSO2 MB 3.0.0 binary pack by default.
      1. andes-client-3.0.0.jar
      2. geronimo-jms_1.1_spec-1.1.0.wso2v1.jar
      3. log4j-1.2.13.jar
      4. slf4j-1.5.10.wso2v1.jar
    2. When you build MQTT samples, the Maven repositories required for the samples should be saved in the pom.xml file of the MQTT samples. For example, the dependencies for the Simple MQTT Client sample should be included in the <MB_HOME>/samples/SimpleMqttClient/pom.xml file. Note that these dependencies are added to the MQTT samples shipped by default with WSO2 MB 3.0.0.

      Code Block
      languagexml
      <dependency>
         <groupId>org.wso2.andes.wso2</groupId>
         <artifactId>andes-client</artifactId>
         <version>0.13.wso2v3</version>
      </dependency>
      <dependency>
         <groupId>org.apache.geronimo.specs.wso2</groupId>
         <artifactId>geronimo-jms_1.1_spec</artifactId>
         <version>1.1.0.wso2v1</version>
      </dependency>
      <dependency>            
         <groupId>log4j</groupId>
         <artifactId>log4j</artifactId>
         <version>1.2.17</version>
      </dependency>
      <dependency>
         <groupId>slf4j.wso2</groupId>
         <artifactId>slf4j</artifactId>
         <version>1.5.10.wso2v1</version>
      </dependency>
      <dependency>
         <groupId>org.wso2.securevault</groupId>
         <artifactId>securevault</artifactId>
         <version>1.0.0-wso2v2</version>
      </dependency>