Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Next »

Published: 01st April 2020

Severity: Medium

CVSS Score: 4.7 (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N) 


AFFECTED PRODUCTS

WSO2 API Manager : 3.0.0
WSO2 IS as Key Manager : 5.9.0
WSO2 Identity Server : 5.9.0


OVERVIEW

A potential Reflected Cross-Site Scripting (XSS) vulnerability has been identified in the Management Console.


DESCRIPTION

The identity provider list user interface is found to be vulnerable to a potential Reflected XSS attack when a user injects a malicious executable script as user input through carbon management console.


IMPACT

By leveraging an XSS attack, an attacker can make the browser get redirected to a malicious website, make changes in the UI of the web page, retrieve information from the browser or harm otherwise. However, since all the session related sensitive cookies are set with httpOnly flag and protected, session hijacking or similar attacks would not be possible.


SOLUTION

If you are using an affected product version, it is highly recommended to migrate to the latest released version to receive security fixes.

Note: If you are a WSO2 customer with Support Subscription, please use WSO2 Update Manager (WUM) updates in order to apply the fix.


  • No labels