Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Current »

Published: 13th May 2020

Severity: High

CVSS Score: 7.6 (CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L)


AFFECTED PRODUCTS

WSO2 IS as Key Manager : 5.5.0 , 5.6.0 , 5.7.0 , 5.9.0

WSO2 Identity Server : 5.4.0 , 5.4.1 , 5.5.0 , 5.6.0 , 5.7.0 , 5.8.0 , 5.9.0

WSO2 Open Banking IS as Key Manager : 5.7.0

WSO2 Open Banking KM : 1.3.0 , 1.4.0


OVERVIEW

A potential security vulnerability has been identified in SMS OTP Authenticatior.


DESCRIPTION

When a SMS OTP Authenticatior is used, allows attackers to bypass SMS OTP Verification by sending a subset of backup codes.


IMPACT

Successful exploitation of this vulnerability allows an attacker to bypass the second factor authentication mechanisms and gain unauthorized access to application.


SOLUTION

If you are using an affected product version, it is highly recommended to migrate to the latest released version to receive security fixes.

You may also apply the relevant fixes based on the changes from the public fix: https://github.com/wso2-extensions/identity-outbound-auth-sms-otp/pull/78

Note: If you are a WSO2 customer with Support Subscription, please use WSO2 Update Manager (WUM) updates in order to apply the fix.

  • No labels