Skip to end of metadata
Go to start of metadata

Prior to installing the WSO2 Gadget Server, it is necessary to have appropriate prerequisite software installed on the system. Verify that the computer has the supported operating system and development platforms before starting the installation.

System Requirements

Confirm that the designated machine meets the following requirements:

Memory

1 GB minimum

Disk

Approximately 200 MB is used for the .zip distribution.

Operating System

Linux, Solaris, MS Windows - 2008 Server/XP/Vista (Not fully tested on Windows Vista), Mac OS X,  Fedora core, Ubuntu, Gentoo

As WSO2 GS is a Java application, it is generally possible to run it on other operating systems with a JDK 1.6.x or higher runtime.
Linux/Solaris is recommended for a production deployment.

Web Browser

The Web Browser used to navigate the GS Management Console requires full Javascript enablement.
NOTE: On Windows Server 2003, it is not allowed to go below the medium security level in Internet Explorer 6.x. 

Required Applications

Application

Purpose

Version

Installation Instructions

Java SE Development Kit (JDK)

  • To launch WSO2 GS as it is a Java application.
  • To build WSO2 GS from the Source distribution (both JDK and Apache Maven are required).
  • To run Apache Ant.

1.6.x

Apache Ant

  • To compile and run the sample clients.

1.7.0 or later

Apache Maven

  • To build WSO2 GS from the Source distribution (both JDK and Apache Maven are required).

2.1.0 or later

Web Browser

  •  To access the Gadget Server Management Console.

 

 




Once the installation prerequisites have been completed, you can proceed to installing the Gadget Server. See:

  • No labels